How to run SPListDisplaySetting on MOSS2010?

Dec 1, 2010 at 1:55 PM
Edited Dec 1, 2010 at 1:56 PM

I was wondering is anyone succeeded to run this feature under MOSS2010.

Installing wsp is not a big problem. I could extract the wsp and install it via stsadm.exe (addsolution command) and afterwards deploy it via Central Admin. Only manual changes in DefaultTemplates.ascx were little bit confusing, namely replacing the <SharePoint:ListFieldIterator runat="server"/> with <Bewise:ListDisplaySettingIterator runat="server"/> on line 120… Because DefaultTemplates.ascx in MOSS2010 is slightly different and ListFieldIterator appears many times. After comparing it to the DefaultTemplates.ascx from MOSS2007 I confirmed that replace should be done in line 124, that is <SharePoint:ListFieldIterator runat="server"/> used in ListForm Rendering template.

Strangely everything seems to be fine and I can set up filed display options(they are also beeing saved), however actual making fields visible does not work. Has anyone succeeded to run this feature under MOSS2010?

Logically thinking this should work OK, of course unless MOSS2010 using something else instead of DefaultTemplates.ascx
Does anyone have some more information on this?

Any suggestions highly appreciated!

Jun 10, 2011 at 2:28 PM

Hi,

I just had the same problem. (OK 6 months later)

Actually to resolve it :

Line 7 : Add <%@ Register TagPrefix="Bewise" Assembly="Bewise.SharePoint.SPListDisplaySetting, Version=1.0.0.0, Culture=neutral, PublicKeyToken=ff7b91f6a8ac16d4" namespace="Bewise.SharePoint.SPListDisplaySetting" %>

Line 127 : Replace by <SharePoint:ListFieldIterator runat="server"/> with <Bewise:ListDisplaySettingIterator runat="server"/>

 

It seems to work.

 

Etienne.

 

Jun 24, 2011 at 11:53 AM
Edited Jun 30, 2011 at 3:04 PM

See my post to configure it : http://somesharepoint.blogspot.com/2011/06/faire-fonctionner-splistdisplaysetting.html

Note : Post edited, URL modified - 30 june 2011

Jun 30, 2011 at 2:27 PM

Hi Etienne.

In this moment I'm need to put this to work on SharePoint Server 2010.

The link to your post is broken. Can you give us an active link? 

Thanks

Jun 30, 2011 at 3:05 PM
Edited Jun 30, 2011 at 3:06 PM

Hi mambru, i corrected my url in my previous post. You can leave me a msg on my blog if it helped you :)

Jun 25, 2012 at 1:40 PM

:-(

didn't work for me after I've applied all the recommendations

http://somesharepoint.blogspot.com/2011/06/faire-fonctionner-splistdisplaysetting.html

nothing gets hidden.

Aug 22, 2012 at 8:42 PM

This also does not work for me.  I applied all the changes per the screen shots at the provided link & made changes per the discussion threads & it still does not hide the fields.  Am using SharePoint 2010 Foundation.

All fields are still visible.

Aug 24, 2012 at 2:09 AM
Did you delete the old .ascx file then iisreset ??

Le 23 août 2012 à 18:10, "thill"<notifications@codeplex.com> a écrit :

From: thill

This also does not work for me. I applied all the changes per the screen shots at the provided link & made changes per the discussion threads & it still does not hide the fields. Am using SharePoint 2010 Foundation.

All fields are still visible.

Aug 24, 2012 at 4:16 PM

Although I have not used it myself, but I have seen a similar SharePoint 2010 control.
May be your could try to use that one http://spcolumnpermission.codeplex.com/