Fields are still visible

Mar 5, 2009 at 1:34 PM

I installed the feature successfully and I'm able to assign different groups to the different list fields. However, all fields are still rendered. I tried to deinstall and re-install - still same behavior.

Could anyone give me a hint what I can check to see if I can find the reason for this (event log and log files are clean)? I appreciate any help or suggestions....

Many thanks in advance

Mar 9, 2009 at 8:43 PM
First, thanks for sharing this solution. It can prove to be very useful.

Second, after a whole lot of trouble-shooting the install (ended up installing the .wsp file using the stsadm tool), I too am having the same issue as described above. I selected NEVER for New/Display/Edit for several fields and they all show up in all forms for the selected list. I verified that the list settings were saved as such and they were. Perhaps this is caused by the way I installed it (everything "appears" to be OK except for this issue).

Guidance is appreciated.
Apr 2, 2009 at 2:58 AM
I am having the same issue, I have used Never and Where for several columns but they all displayed regardless of the filters.

Any clues?


Apr 16, 2009 at 2:32 PM
Edited Apr 20, 2009 at 12:35 PM
Same issue here.  I did test the feature on a vanilla single server in a VM and it worked fine, but since installing it on our live server farm hiding fields does not work on any of the default views in a list.

Ignore that, there is a solution.  A specific file on the front-end web servers in our farm was not getting updated as part of the feature install.  Follow the install instructions here:
Jan 28, 2011 at 10:39 AM

I am also facing the same issue. My installation was successful but even after setting "Never" flags, fields are still visible on New & Edit forms.

Is there any workaround for the issue?

I have x64 bit servers.