This project is read-only.
2
Vote

Does not work on Windows 2008, 64 bit MOSS 2007

description

First I tried running the MSI installer and I was not able to install on 64 bit. I compiled the source code and installed the WSP package on MOSS 2007 (64 bit on 64 bit Windows 2008). The package was installed and I can configure the settings using settings page. However, the forms still show all fields and do not seem to refer to the settings defined.
 
The solution (including installer) seems to work on 32 bit system.
 
Any ideas on why it would work on 32 bit and not on 64 bit instance?

comments

lmarrou wrote Aug 11, 2010 at 9:17 AM

Hello I am experiencing the exact same issue, any recent updates ?

Many thanks.

wrote Aug 11, 2010 at 9:18 AM

AjayMandke wrote Aug 11, 2010 at 5:30 PM

To get the solution to work, here is what I did-

1) Go to controltemplates folder on SharePoint server [c:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\12\TEMPLATE\CONTROLTEMPLATES]
2) backup the DefaultTemplates.ascx file as DefaultTemplates.ascx.bak or like that (file size 139,157 bytes)
3) Copy the modified DefaultTemplates.ascx file from the successful installation on 32 bit (file size 139,363 bytes)
Repeat this on all SharePoint server in farm.
4) Restart IIS on all sharepoint servers

I believe the updated DefaultTemplates.ascx has the code that looks for the display settings configured on settings page. This modified control does not get installed at correct place on 64 bit MOSS.

wrote Feb 14, 2013 at 8:00 PM